Back to overview
Maintenance
Scheduled Maintenance: Client Portal
Feb 28, 2026 at 12:33am UTC
–
Feb 28, 2026 at 1:30am UTC
Affected services
Client Portal
Resolved
Feb 28, 2026 at 1:30am UTC
This maintenance has now been completed and the Client Portal is back online.
Affected services
Created
Feb 28, 2026 at 12:33am UTC
The Client Portal is undergoing scheduled maintenance to prepare for a system upgrade. It will be inaccessible to all users while the maintenance is in progress. We apologise for any inconvenience caused.
Affected services